TL;DR – It doesn’t work yet 🙁

I am trying to move my mcgaw.eu to my new server, however, I have been adding things after the local part deliminated with a +, for a while now, while this works out the box with symbiosis, it doesn’t seem to work with Sentora out the box.

I am running Ubuntu Ubuntu 14.04.4 LTS “Trusty” and “postconf -d | grep mail_version” gives me “mail_version = 2.11.0”.

I have installed Sentora (I assume it is the same on zpanel) which sets most of the configuration up for Postfix up, I have made some changes to allow me to use certificates for IMAP and SMTP SSL,

My postfix config file is here, and Postfix master process configuration file is here, and dovecot -n gives me the following this.

I am trying to send an email to [email protected] and [email protected] (sending from an iCloud account), it works to [email protected], the lines from mail.log are as follows:

Mar 11 17:48:07 njoror postfix/smtpd[32706]: connect from mr11p26im-asmtp004.me.com[17.110.86.109]
Mar 11 17:48:07 njoror postfix/smtpd[32706]: Anonymous TLS connection established from mr11p26im-asmtp004.me.com[17.110.86.109]: TLSv1.2 with cipher DHE-RSA-AES128-GCM-SHA256 (128/128 bits)
Mar 11 17:48:08 njoror postfix/smtpd[32706]: 1BAF055AB6: client=mr11p26im-asmtp004.me.com[17.110.86.109]
Mar 11 17:48:08 njoror postfix/cleanup[32710]: 1BAF055AB6: message-id=<[email protected]>
Mar 11 17:48:08 njoror postfix/qmgr[32599]: 1BAF055AB6: from=<[email protected]>, size=1513, nrcpt=1 (queue active)
Mar 11 17:48:08 njoror postfix/pipe[32605]: 1BAF055AB6: to=<[email protected]>, relay=dovecot, delay=0.43, delays=0.34/0.01/0/0.09, dsn=4.1.1, status=SOFTBOUNCE (user unknown)
Mar 11 17:48:08 njoror postfix/smtpd[32706]: disconnect from mr11p26im-asmtp004.me.com[17.110.86.109]

vs

Mar 11 17:49:23 njoror postfix/smtpd[32706]: connect from mr11p26im-asmtp004.me.com[17.110.86.109]
Mar 11 17:49:23 njoror postfix/smtpd[32706]: Anonymous TLS connection established from mr11p26im-asmtp004.me.com[17.110.86.109]: TLSv1.2 with cipher DHE-RSA-AES128-GCM-SHA256 (128/128 bits)
Mar 11 17:49:24 njoror postfix/smtpd[32706]: 33D2355AB9: client=mr11p26im-asmtp004.me.com[17.110.86.109]
Mar 11 17:49:24 njoror postfix/cleanup[32710]: 33D2355AB9: message-id=<[email protected]>
Mar 11 17:49:24 njoror postfix/qmgr[32599]: 33D2355AB9: from=<[email protected]>, size=1249, nrcpt=1 (queue active)
Mar 11 17:49:25 njoror postfix/smtpd[32706]: disconnect from mr11p26im-asmtp004.me.com[17.110.86.109]
Mar 11 17:49:26 njoror postfix/pipe[32605]: 33D2355AB9: to=<[email protected]>, relay=dovecot, delay=1.8, delays=0.63/0/0/1.2, dsn=2.0.0, status=sent (delivered via dovecot service)
Mar 11 17:49:26 njoror postfix/qmgr[32599]: 33D2355AB9: removed

Looking at the lines from mail.log it looks like it thinks there should be a user called [email protected], this has been puzzling me for a while, I was wondering if any one on here could see what was wrong, and what I needed to change, Looking at a few examples and online guides I thought I had covered all the bases.

If any one can see what I have done wrong I would appreciate the answers in the comments.