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Overview 

Many features that you create in Fusion 360 start with a 2D sketch. In order to create intelligent and 

predictable designs, a good understanding of how to create sketches and how to apply dimensions and 

geometric constraints. Fusion does support 3D sketches although, in this module we will cover basic 

sketching tools to create and edit a 2D sketch. 

Learning Objectives 

In this section you will learn how to: 

 Create a 2D sketch 

 Create geometry in a sketch 

 Use constraints to position geometry 

 Use dimensions to set the size of geometry 

A Fusion design can contain multiples sketches. The sketch is an object that contains the geometry to 

define profiles. Your sketches are listed in the browser. Sketches are also listed in the timeline in 

parametric designs.  

Sketches must be created on a plane. You can use the origin planes, construction planes, or a flat model 

face to define a sketch. 

Create Sketch: In this exercise, you create a new Fusion design then create a new sketch in the design. 

Step 1 – Create a new design 
 

1. Launch Fusion 360. 
2. Start a new design. 

 
This creates a new design where you will create 
geometry. 

 
Launch Video 

Step 2 – Create a new sketch 
 

1. Select Sketch > Create Sketch. 
 
 
 

 

http://youtu.be/OtkmiPeUxqE?list=PLmA_xUT-8UlJpYbha60oAQMxFlBY371oZ
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Step 3 – Select the sketch plane 
 

1. You are now prompted to select a “plane” 
to sketch on. 

2. Select the “Front” (XY) plane. 
 
You can create sketches on one of the 3 default 
planes, on a custom construction plane or on an 
existing model face.  More on this later. 

 
 

Sketches contain vector data. They are made of lines, circles, arcs and other curves. They are not artistic 

sketches or renderings.  

There are many commands available to create and edit sketch geometry.  

Basics: This exercise uses a few sketch commands to get you comfortable.  We will delete the geometry 

later. 

Step 1 – Create a circle 
 

1. Select Sketch > Circle > Center Diameter 
Circle. 

2. Select anywhere in the screen to define the 
center point. 

3. Move the mouse out until you have a size you 
like. 

4. Click again to complete the command. 
 
Sketches usually consist of many types of “primitive” 
geometry added together. 

 
Launch Video 

Step 2 – Create a rectangle 
 

1. Select Sketch > Rectangle > 2-Point 
Rectangle. 

2. Select anywhere in the screen to start the 
rectangle. 

3. Move the mouse out until you have the size 
you want. 

4. Click again to complete the command. 
 
There are different ways to create circles and 
rectangles.  Experiment with some of the other 
options in the menu.  See more here: 

 
Launch Video 

https://www.youtube.com/watch?v=OtkmiPeUxqE&list=PLmA_xUT-8UlJpYbha60oAQMxFlBY371oZ#t=81
https://www.youtube.com/watch?v=OtkmiPeUxqE&list=PLmA_xUT-8UlJpYbha60oAQMxFlBY371oZ#t=126
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http://help.autodesk.com/cloudhelp/ENU/Fusion-
Form/files/GUID-24E2EF31-21F1-4E10-BC17-
4BE688356DA2.htm 

Step 3 – Create a slot 
 

1. Select Sketch > Slot > Center to Center Slot. 
2. Select anywhere in the screen to start the 

slot. 
3. Move out until you have a length you like 

then click to establish the slot length. 
4. Now move out to define the width of the slot. 
5. Click again to complete the command. 

 
You will notice the various symbols that are being 
created on the geometry.  These are “constraints.”  
They control the relationships between the entities in 
the sketch.  
 

 
Launch Video 

Step 4 – Constrain the slot 
 

1. Select Sketch > Constraints.  
2. Select one of the straight lines in the slot. 
3. Select Horizontal/Vertical. 

 
The Horizontal/Vertical constraint sets the geometry 
to whichever is closer: horizontal or vertical. 
 
By adding a horizontal relationship to the slot we 
have “fixed” its movement.  Try dragging on some of 
the points to see the behavior. 

 
 

https://www.youtube.com/watch?v=OtkmiPeUxqE&list=PLmA_xUT-8UlJpYbha60oAQMxFlBY371oZ#t=154
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Step 5 – Dimension the width of the slot 
 

1. Select Sketch > Sketch Dimension. 
2. Select one of the horizontals lines. 
3. Move the cursor out and click to place the 

dimension. 
4. Enter a value for the dimension. 

 
Typically we place dimensions after placing geometry.  
This dimension now controls the length of the slot.  
You can double click it to change the value. 
 

 
 

Step 6 – Dimension the radius of the slot 
 

1. Now select the right arc (the dimension 
command should still be active). 

2. Place the dimension. 
3. Press Esc to end the command. 

 
Notice that you cannot place a second dimension on 
the left arc.  This is because it would conflict with the 
other constraints we have created.    

 

Step 7 – Sketch a profile 
 

1. Select Sketch > Line.  
2. Draw the following shape by clicking in this 

order. 
3. Make sure on the last line you “connect” it to 

the start point. 
 
If you finish it correctly you will see that the shape is 
shaded in.  Notice that some constraints were created 
for you if you picked it right.  

Launch Video 

Step 8 – Constrain the profile 
 

1. Select Sketch > Constraints.  
2. Select these two lines. 
3. Select Perpendicular. 

 
Feel free to experiment with other constraints 
between the lines.   

 

https://www.youtube.com/watch?v=OtkmiPeUxqE&list=PLmA_xUT-8UlJpYbha60oAQMxFlBY371oZ#t=353
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Step 9 – Constrain the profile 
 

1. Select Sketch > Constraints.  
2. Select these two lines. 
3. Select Equal. 

 
You see how you can create more intelligence in the 
models with relationships 

 
 

Step 10 – Dimension the profile 
 

1. Select Sketch > Sketch Dimension.  
2. Place a dimension on the vertical line. 
3. Enter 100 mm for the value and note the 

name of the dimension, d3 in this case. 
4. Place a dimension on the top horizontal line. 
5. Enter d3 + 50 for the value. 
6. Now change the value of the vertical 

dimension and see the horizontal update. 
 
There is another method to make relationships.  To 
modify these relationships you can go to: 

        Modify > Change Parameters 

 

 

Step 11 – Delete the sketch profiles 
 

1. Zoom out to see everything. 
2. Select everything in the sketch by dragging a 

selection box. 
3. Press Delete. 

 
You should now have an empty sketch to start the 
next part of the lesson. 
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Base Sketch: Now we will begin to create some real sketch geometry that will be used to create 3D 

geometry.  

Step 1 – Sketch a circle 
 

1. Select Sketch > Circle > Center Diameter 
Circle. 

2. Select the origin (center point of the grid). 
3. Drag out a circle about 30 mm in 

Diameter. We will add the specific size 
later. 

 
 

 
Launch Video 

Step 2 – Sketch another circle 
 

1. Select Sketch > Circle > Center Diameter 
Circle. 

2. Create another circle in roughly this 
position. 

 
Don’t worry about a specific size or position now 
we will fix that later. 

 

 

Step 3 – Create lines 
 

1. Select Sketch > Line. 
2. Click on the left circle to start the line. 
3. Hold Shift then click again where shown to 

make the first line. Holding shift locks the 
line tangent to the circle. 

4. Click once more on the right circle at the 
position where the line is tangent to the 
circle. 

5. Press Esc to end the command. 

 
Launch Video 

Step 4 – Fillet the lines 
 

1. Select Sketch > Fillet. 
2. Select the intersection of the two lines. 
3. Type 10 mm into the input box. 
4. Press Enter. 

 
When you create a fillet “tangent” relations are 
added to the sketch.    

http://youtu.be/3EGWWT65Vrs?list=PLmA_xUT-8UlJpYbha60oAQMxFlBY371oZ
http://youtu.be/3EGWWT65Vrs?list=PLmA_xUT-8UlJpYbha60oAQMxFlBY371oZ
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Step 5 – Complete the profile 
 

1. Select Sketch > Line.  
2. Select the left circle (2) as shown. 
3. Hold Shift then click near the number (3) 

as shown. 
4. Hold down the left button on the end 

point of the line and drag to create an arc. 
5. Click (5).  
6. Click on the right circle (6). 

 
If you make a mistake just feel free to delete the 
lines and try again.   

 
Launch Video 

 

Relationships: Now we will see how to create dimensions and constraints for our sketch. 

Step 1 – Display the Constraints dialog box 
 

1. Select Sketch > Constraints.  
 
This brings up the dialog box where you can create 
relationships between sketch entities.   Constraints 
will determine how your sketch behaves.  Once a 
relationship like tangent or perpendicular is 
applied then it is persistent as you continue to 
modify the sketch. 

 
 

  

http://youtu.be/3EGWWT65Vrs?list=PLmA_xUT-8UlJpYbha60oAQMxFlBY371oZ
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Step 2 – Add tangent constraints 
 

1. Select the Tangent constraint.  
2. Apply tangent constraints at the locations 

shown if they do not already exist. 
3. Make sure you have 8 tangent symbols on 

your sketch. 
 
You may have noticed that there are already some 
of these created as you were sketching.  Many 
commands in Fusion 360 allow you to create 
relationships “on-the-fly.”  As you become more 
familiar with the tool this will make more sense.  

 
 

Step 3 – Dimension the circle 
 

1. Close the constraints dialog box. 
2. Select Sketch > Sketch Dimension. 
3. Select the left circle. 
4. Click again to place the dimension. 
5. Change the value to 31mm. 
6. Press Enter. 

 
This is how we size our sketch.  It is very common 
to draw things out in rough position then go back 
and add sizing information.  Later we will show 
how to add this at creation. 

 
 

Launch Video 

Step 4 – Dimension the profile 
 

1. Repeat the process for the right circle and 
two arcs. 

2. Change the values to match those shown 
here. 

 
Once you have started the dimension command it 
stays active.  You do not have to go to the menu 
each time to activate it. 

 

  

https://www.youtube.com/watch?v=3EGWWT65Vrs&list=PLmA_xUT-8UlJpYbha60oAQMxFlBY371oZ#t=336
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Step 5 – Add more dimensions 
 

1. Make sure the dimension command is still 
active. 

2. Select the center point of the left circle. 
3. Select the center point of the lower arc. 
4. Place the dimension to the left center of 

the two points. 
5. Don’t change the value yet (Don’t worry if 

your value is different). 
 
Depending on where you place the dimension you 
get different results.  You can make horizontal, 
vertical and shortest distance dimensions by 
where you drag the dimension when you are 
placing it.  Once the dimension is placed you can’t 
change it.  If you make a mistake delete the 
dimension and start again.   

 
 

Step 6 – Add more dimensions 
 

1. Select the center point of the left circle. 
2. Select the center point of the lower arc. 
3. This time place the dimension to the lower 

center position to create a horizontal 
dimension. 

4. Place the dimension but don’t edit the 
values. 

 
Sometimes it is better to place your dimensions 
first before changing the values.  When some 
geometry doesn’t have any relationships yet it can 
behave in unexpected ways.   

 
 

Step 7 – Add more dimensions 
 

1. Repeat the process for the upper arc and 
the left circle. 

2. Create two dimensions between the left 
circle and the center point of the right 
circle. 

 
Your sketch should look like this although you will 
have different values for the dimensions.  We will 
change the values in the next step. 
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Step 8 – Set the dimension values 
 

1. Double click a dimension to change its 
value. 

2. Change the values of the dimensions to 
match those shown. 

3. Follow the order of the numbered 
balloons for the best results. 

 
What is happening under the hood is the software 
is “solving” all the relationships at once.  It is 
possible that you will try to enter a dimension that 
conflicts with the other values.  As you become 
more familiar with the behavior you will get a 
sense of the best order to makes changes for the 
desired result. 

 

 

The end result of a sketch is often to create a 3D feature. Fusion automatically discovers closed profiles 

that can be used in 3D features.  

Creating Geometry: Next we will use this sketch to create 3D geometry. 

Step 1 – Leave the sketch environment 
 

1. Select Stop Sketch. 
 
This completes the sketch.  If you need to edit the 
sketch again you can select it from the sketch 
folder in the browser on the left of your screen.  
You can also rename it from there. 

 
Launch Video 

Step 2 – Create 3D geometry 
 

1. Select Modify > Press Pull. 
2. Select the three profiles of the sketch so 

that the entire area is highlighted. 
3. Enter a value of 48.25 mm. 
4. Press OK. 

 
You have now created a base 3D extrusion 

 
 

Launch Video  

  

https://www.youtube.com/watch?v=3EGWWT65Vrs&list=PLmA_xUT-8UlJpYbha60oAQMxFlBY371oZ#t=336
https://www.youtube.com/watch?v=3EGWWT65Vrs&list=PLmA_xUT-8UlJpYbha60oAQMxFlBY371oZ#t=653
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Creating Sketch References: Here will use the geometry we just created to make more sketches. 

Step 1 – Create a new sketch 
 

1. Select Sketch > Create Sketch. 
2. Select this face of the geometry. 

 
Previously we sketched on an origin plane.  Now 
we are sketching directly on the model geometry. 

 
Launch Video 

Step 2 – Create a circle 
 

1. Select Sketch > Circle > Center Diameter. 
2. Select the center point of the right circle. 
3. Drag the circle then type the value 10 mm. 
4. Press Enter twice. 
5. You can move the dimension out if you 

want as well. 
 
This circle is now “locked” to the center of the 
original boss feature 

 

 
Launch Video 

Step 3 – Create additional circles 
 

1. Repeat the process for two more circles. 
2. Make sure to attach the center to the 

center of the lower arc and the left circle. 
3. Use a diameter of 8 mm for both circles. 
4. Select Stop Sketch. 

 
This circle is now “locked” to the center of the 
original boss feature. 
 

 

Step 4 – Cut holes in the body 
 

1. Select Modify > Press Pull. 
2. Select the three circles. 
3. Select: Cut, All, and Flip Direction. 
4. Select OK. 

 
You created a cut in the geometry that references 
the position of the base arcs.  

 
Launch Video 

https://www.youtube.com/watch?v=3EGWWT65Vrs&list=PLmA_xUT-8UlJpYbha60oAQMxFlBY371oZ#t=686
https://www.youtube.com/watch?v=3EGWWT65Vrs&list=PLmA_xUT-8UlJpYbha60oAQMxFlBY371oZ#t=721
https://www.youtube.com/watch?v=3EGWWT65Vrs&list=PLmA_xUT-8UlJpYbha60oAQMxFlBY371oZ#t=721
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Challenge: Congratulations you have finished the model!  If you want to challenge yourself try to use the 

techniques in here to finish the model.  Otherwise you will learn a slightly different method of creating 

this part in the modeling lesson. 

   

 
What we’ve done so far 

 
Completed Rocker Arm Model 

 

 

 

 


