Autodesk Fusion 360: Sculpt

Overview
Sculpting in Fusion 360 allows for the intuitive freeform creation of organic solid bodies and surfaces by
leveraging the T-Splines technology. In the Sculpt Workspace, you can rapidly explore forms by simply
pressing and pulling on subdivided surfaces. This “hands-on” approach to 3D modeling allows for fast
iteration and early stage conceptualization within Fusion 360. Sculpted forms are easily converted to
solid bodies, and can be used in conjunction with Fusion 360’s solid modeling commands.
Modeling with T-Splines is unlike any other subdivision-modeling tool. One of the main advantages of TSplines is the ability to add detail only where necessary.

This may not sound like much, but this is one of the biggest challenges in most subdivision 3D modeling
tools. By only adding data in necessary locations, a single T-Spline surface can be incredibly smooth,
while still having areas of high detail and remaining easy to manipulate.
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Learning Objectives
In this section you will learn how to:





Create a T-Spline form
Modify a T-Spline form
Add details to a T-Spline form
Create a T-Spline form based on a reference image
Creating T-Spline Forms

Open Fusion 360 design file and enter the Sculpt Workspace: In this section you open the introductory
design file and go to the Sculpt workspace to create T-Spline forms.
Step 1 – Open the Data Panel
1. Open the Data Panel by clicking on the
icon located at the top left of the menu
bar.
2. The Data Panel will slide open.

Step 2 – Open the design
In this module we will be using the
03_Sculpting_Introduction.f3d file to complete the
exercise. If you haven’t set up a new project and
uploaded the necessary designs, please follow the
steps in the Introduction module.
1. At the top left of the Data Panel, select the
project where you uploaded the
03_Sculpting_Introduction.f3d file.
2. Navigate to this design and either doubleclick or right-click and select open.
3. When the design has opened in your
modeling window, click on the icon to
close the Data Panel.
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Step 3 – Go to the Sculpt workspace
1. Click Create > Create Form to enter the
Sculpt workspace.
2. A dialog box appears, telling you to click
Finish Form to return to the model
workspace whenever you’re finished
sculpting.
3. Click OK.

Launch Video

You will notice that the top ribbon will change to
include commands specific to sculpting.

Create a T-Spline Primitive Form: In this section you learn how to create the most basic T-Spline form: a
Primitive.
Step 1 – Select the T-Spline primitive
1. Click the drop-down arrow under Create
to expand the list of creation commands.
2. You will see a list of T-Spline primitives:
Box, Plane, Cylinder, Sphere, Torus, and
Quadball.
3. Click on Box to create a T-Spline box.

Launch Video
Step 2 – Position the box
1. Click the bottom plane to place the
bottom of the box on this plane.
2. Click on the origin to specify the center
point of our box’s 2D profile.
3. Move your mouse and click again to
specify the size of the rectangle.

Launch Video
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Step 3 – Dimension the box
1. In the new dialog window set the length to
175mm, and the width to 150mm
respectively by entering these numbers.
2. Drag the arrow pointing up from the box,
and set the height equal to 75mm.
When setting the height, if it is changing at too
large of increments, simply zoom in to reduce the
size of each step.
Step 4 – Subdivide the box

Launch Video

1. In the dialog window set the length faces
equal to 3.
2. Drag the set of arrows pointing up in the
positive direction to increase the number
of width faces, and set it equal to 3.
3. Click OK to complete the primitive setup.

Launch Video
Step 5 – Finish form
1. The last step is to tell Fusion 360 that we
are – temporarily - finished sculpting our
first Form.
2. At the top right of the Ribbon, click Finish
Form.
3. You will return to the Model workspace.
With our first T-Spline primitive complete, it’s time
to learn more methods for creating T-Spline forms.
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T-Spline Form Creation – Revolve: In this section you learn how to create a T-spline form using the
revolve command and a sketch. The Revolve command creates a form by rotation 2D geometry about a
fixed axis.
Step 1 – Hide the previous T-spline form
1. In the Browser, click the drop-down arrow
next to your Bodies folder
2. Click the light bulb next to Body1 to turn
off the visibility.
3. Click Create > Create Form.
We hide our T-Spline primitive in order to keep
things neat, but we’ll be returning to it later on.
Launch Video
Step 2 – View the revolve sketch
1. In the Browser, click the drop-down arrow
next to your Sketches folder.
2. Click the light bulb next to Revolve to turn
on the visibility of the Revolve sketch.

Step 3 – Start the Revolve Command
1. Click Create > Revolve
In addition to Revolve, you will see three more
sketch-based form creation commands: Extrude,
Sweep, and Loft.
Launch Video
Step 4 – Select the profile and axis
1. Click on the sketch curve shown in the
workspace to specify the Profile.
2. Click no selection in the dialog window
next to Axis to enable selection.
3. Click on the Z-axis shown in Blue.
If you’d like Z to be “up,” this can be changed
under the preferences.
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Step 5 – Explore the revolve details
1. In the Revolve dialog window, change the
Type from Full to Angle.
2. Enter 90 degrees for the angle.
3. Change the Direction from One Side to
Symmetric.
4. Click OK.
Launch Video
Step 6 – Finish form
1. Click Finish Form to complete this
Sculpting session.
2. You return to the Model workspace.
3. The bottom timeline populates with our
second T-Spline form!

T-Spline Form Creation – Sweep: In this section you learn how to create a T-spline form using the Sweep
command and two sketches. The Sweep command will create a form by moving a 2D profile on a
particular path.
Step 1 – Toggle visibility
1. Hide the previously created Body.
2. Hide the Revolve Sketch.
3. Show the sketches called Sweep Path and
Sweep Profile.
Use the light bulb icons to control the visibility of
objects.
Launch Video

6

Autodesk Fusion 360: Sculpt
Step 2 – Start the sweep command
1. Click Create > Create Form.
2. Click Create > Sweep.

Step 3 – Select the Profile and Path
1. Click the Square profile visible in the
workspace to specify the profile.
2. Click no selection next to Path to begin
selecting a path to sweep along.
3. Select the curve profile for the Path.
Launch Video
Step 4 – Closer match the profile
1. To closer match our rounded-square
profile, we need to increase the number of
faces for the profile.
2. In the dialog window, set the number of
faces for the Profile equal to 24.
The greater number of faces, the closer the body
matches the path. You need to balance the
number of faces with the accuracy of the body.

Launch Video

Step 5 – Change the sweep orientation
1. In the dialog window, change the
Orientation from Perpendicular to Parallel.
2. Observe how the sweep behavior
drastically changes.
3. Change the Orientation back to
Perpendicular.
For a sweep, the optimal orientation is more often
than not Perpendicular.
Launch Video
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Step 6 – Specify the sweep distance
1. Drag the arrow at the end of the Path to
alter the sweep distance. In addition to
using this arrow, we can set the distance in
the dialog window.
2. In the dialog window, set the distance
equal to 0.5.
3. The sweep now travels half the length of
our Path.
4. Click OK.
Launch Video
Step 7 – Finish form
1. Click Finish Form to complete this
Sculpting session.
2. You return to the Model workspace.
3. The bottom timeline populates with our
third T-Spline form!

T-Spline Form Creation – Loft: In this section you learn how to create a T-spline form using the Loft
command and three sketches. As you will see, the Loft command creates a transitional form between
two profiles.
Step 1 – Toggle visibility
1. Hide the previously created Body.
2. Hide the two Sweep sketches.
3. Show the sketches called Loft Centerline,
Circle, and Triangle.

Launch Video
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Step 2 – Start the Loft command
1. Click Create > Create Form.
2. Click Create > Loft.

Step 3 – Select the profiles
1. Click the Triangular profile in the canvas.
2. Click the Circular profile in the canvas.
3. A transitional shape between the triangle
and the circle is previewed.
This creates a form in a straight-line between our
two profiles. In the next step, we add an optional
centerline for more control.

Launch Video

Step 4 – Specify the centerline
1. Click the centerline curve visible in the
canvas.
2. You receive an error because Fusion thinks
this is a third profile.
3. To specify this curve as a centerline select
Convert to Centerline under Swap in the
dialog window.

Launch Video

Step 5 – Closer match the profile
1. To closer match our triangular profile, we
need to increase the number of faces for
the profile.
2. In the dialog window, set the number of
faces for the Width equal to 16.
3. Click OK.
The greater number of faces, the closer the body
matches the profile.
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Step 6 – Finish form
1. Click Finish Form to complete this
Sculpting session.
2. You return to the Model workspace.
3. The bottom timeline populates with our
fourth T-Spline form!
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Modify a T-Spline Form
Now that we learned different methods for creating T-Spline forms, the next step is to learn how to
modify them. Being that sculpting in Fusion 360 allows for freeform shape manipulation, it’s very rare
that a T-spline form does not require any editing. If it did not, then it might as well have been performed
in the Model or Patch workspaces. It’s important to create forms in the Sculpt workspace that you
intend to be organic.
Edit Form: In this section you learn how to modify a T-Spline body with the primary T-Spline modifying
command, Edit Form. We start by editing the first T-Spline primitive that we created, the Box.
Step 1 – Toggle visibility
1. Hide the previously created Body.
2. Hide any visible sketches.
3. Turn on the visibility of our primitive TSpline Box – Body 1.

Launch Video
Step 2 – Edit form operation
1. In the parametric timeline, locate the 4 TSpline form icons.
2. Hover over the first icon and confirm that
the primitive Box becomes highlighted.
3. Right-click on this form icon in the timeline
and select Edit.
4. You roll back to that point in time and
enter the Sculpt workspace again.

Step 3 – Start the Edit Form command
1. Click Modify > Edit Form. There are many
modifying commands in the Sculpt
workspace.
Alternatively, you can click the large Edit Form icon
that resides in the ribbon by default.

Launch Video
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Step 4 – Select geometry to edit
1. The Edit Form command can directly
manipulate Faces, Edges, and Vertices.
2. Click on a top face located at one of the
corners of the box.
3. The manipulator displays on the face with
an assortment of tools.
Directly manipulating a face creates the greatest
changes in your form, while manipulating a single
vertex will result in smaller changes.
Step 5 – Single direction translation
1. Click and drag on the arrow pointing up to
translate the selected face up by 30 mm.
2. The surrounding faces move to maintain
continuity.

Launch Video
Step 6 – Planar translation
1. Click and drag on one of the white boxes
to translate the selected face on a plane.
2. More surrounding faces move to maintain
continuity throughout the form.
Planar translation is incredibly useful, as you will
often want to move geometry in all directions but
one.

Launch Video
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Step 7 – More translation
1. Select a single edge.
2. Use any of the translate manipulators to
compare the effect.
3. Select a single vertex.
4. Translate this vertex to see how this
creates more subtle changes
In the following sections we cover the
manipulators: scale and rotate.

Launch Video

Edit Form – Rotate and Scale: In this section you learn how to modify T-Spline geometry using the
rotate and three scale manipulators.
Step 1 – Rotation
1. Make sure that at least one face is
selected.
2. Click and drag one of the circular arcs to
rotate the selected geometry about a
single axis.
Be careful not to rotate geometry too far, as selfintersecting faces, or geometry that twists through
itself will not result in a watertight solid body.
Launch Video
Step 2 – Single direction scaling
1. Make sure that at least one face is
selected.
2. Click and drag one of the straight lines to
scale the selected face in one direction.
3. You will see that scaling in each axis will
have a significantly different effect.

Launch Video
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Step 3 – Planar scaling
1. Make sure that at least one face is
selected.
2. Click and drag one of the small corner
manipulators to scale the selected face
along a plane – or in two directions.
Similar to planar translation, it is often very useful
to scale geometry in two directions.

Launch Video
Step 4 – Universal scaling
1. Make sure that at least one face is
selected.
2. Click and drag the circular manipulator at
the center of the manipulator.
3. Dragging left or right will scale the
geometry in all directions up or down.
With the basics of editing a T-Spline form covered,
we move on to a very useful function of the Edit
Form command: Adding additional geometry.

Launch Video

Edit Form – Add Geometry: In this section you learn how to use the Edit Form command to add
geometry to your T-Spline form, rather than “stretching” it.
Step 1 – Adding geometry
1. Select a single face of your T-Spline form.
2. Hold the alt-option on Mac or alt key on
Windows (with the Edit Form command
active).
3. Click and drag the single arrow to add
geometry outward from the selected face.
4. Let go of the alt-option/alt key as well as
the left-mouse button.
You will notice that this has a much different effect
from simply stretching a face in a single direction.
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Step 2 – Box Mode
1. We will now turn on Box Mode, which
displays a simplified control cage of our TSpline form.
2. On a Mac: hold control and press 1.
3. On a PC: hold alt and press 1.
4. The control frame for the T-Spline body is
displayed.
Box mode improves performance and can be
useful in finding problem areas.

Launch Video

Step 3 – Add geometry in Box Mode
1. With Box mode enabled, hold altoption/alt.
2. Translate outwards in a single direction
again.
3. You will see a similar effect as before, but
with slightly faster performance.

Launch Video
Step 4 – Return to Smooth Mode
1. To view how a T-Spline form truly looks,
we will return to Smooth Mode.
2. On a Mac: hold control and press 3.
3. On a PC: hold alt and press 3.

Launch Video
Step 5 – Finish form
1. We’ll temporarily finish editing our TSpline form.
2. Click Finish Form in the Ribbon.
3. You will return to the model workspace.
That wraps up our introduction to editing a T-
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Spline form! Next, we take a look at adding
additional detail to a T-Spline form by inserting
and deleting edges.

Add Details to a T-Spline Form
T-Spline forms are flexible in the fact that edges can be inserted at particular locations, as well as
deleted. It is very common to add additional edges to a T-Spline form in the early design stages and
remove excess edges towards the end to ensure a very smooth form.
Insert T-Spline Edge: In this section you will learn how to insert an edge in a T-Spline form and how this
affects the shape.
Step 1 – Create a New T-Spline form
1. Enter the Sculpt workspace by clicking
Create > Create Form.
2. Create another Box primitive whose
length, width, and height are 100mm,
100mm, and 200mm.
3. Set the number of length, width, and
height faces equal to 4, 2, and 2.
4. Click OK.

Launch Video

Step 2 – Start the Insert Edge command
1. Click Modify > Insert Edge.
2. Double-click on one of the middle edges
to select the entire middle loop.
The input for the Insert Edge command tells Fusion
what reference edge you’d like to add. Selecting a
single edge adds one edge, while selecting a loop
adds a second loop.
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Step 3 – Adjust the insert location
1. Click and drag the manipulator to adjust
the position of the inserted edge.
2. The value between 0 and 1 can be thought
of as the percent between two adjacent
edges.
3. By hand, or with the text field, set the
Insert Location equal to 0.75.
Launch Video
Step 4 – Adjust the insert specifics
1. With the Insert Mode set to Simple, the
edge will be added, but the form will
change, and this is okay for this
application.
2. Change the Insert Side from Single to
Both.
3. Click OK.
Tip: If you want to add an edge, but maintain the
existing form, set the Insert Mode to Exact.
Step 5 – Explore the result
1. After the edges are inserted, the form will
certainly change. The top and bottom
edges become sharper due to the
additional edge.
2. Double click on the middle edge loop.
3. Start the Edit Form command.
4. Universal scale this edge loop inward
using the center manipulator.
5. Click OK.
Launch Video
As you can see, having additional edges allows for
more complex form creation. In the next section
we take a look at deleting an edge, and the effect
that has on the form.
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Delete T-Spline Edge: In this section you learn how to remove an edge in a T-Spline body and how this
affects the shape.
Step 1 – Select an edge loop
1. Select the recently added upper edge loop
by double-clicking on one of its edges.
2. Click Modify > Delete.
3. Click Finish Form.
The form has again drastically changed, as there
now must be a smooth transition between the
middle and top loops.
Launch Video

There are many more commands for adding addition detail to a T-Spline form, but knowing how to
insert and delete edges is at the core of sculpting in Fusion 360.

Create a T-Spline Form from a Reference Image

In this section you learn how to create a T-Spline form based on a calibrated reference image. With the
freeform capabilities that come along with sculpting Fusion 360, this is a very common workflow. Let’s
get started by creating with a blank slate by creating a New Design.
Design Setup – Attach Canvas: The first step is to learn how to attach a reference image to a particular
plane and calibrate it to ensure an accurate design.
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Step 1 – Attach a canvas
1. Click Insert > Attached Canvas.
2. Select the YZ Plane (between the green
and blue axes) to set the Canvas’
orientation.
3. In the dialog window, click the Select
Image button and navigate to the
03_UtilityKnife.jpg file in the downloaded
.zip folder.
Step 2 – Setup the canvas

Launch Video

1. If necessary, rotate the canvas 90 degrees
to orient it properly
2. Lower the opacity to 85.
3. Check the box for Display Through to
ensure that the canvas can be seen
through your T-Spline form.
4. Click OK.
Launch Video
Step 3 – Start the calibrate command
1. We need to calibrate our canvas to make
sure our utility knife fits in our palm, and
not on our fingertip!
2. In the Browser, click the drop-down arrow
next to the Canvases folder.
3. Right-click on UtilityKnife and select
Calibrate.
Launch Video
Step 4 – Calibrate the canvas
1. Click Right on the ViewCube to view the
utility knife from the side.
2. Click once at the front of the utility knife.
3. Click once at the back of the utility knife.
4. Enter the approximate length, 180 mm.
5. The canvas will scale up accordingly.
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Create Primitive Form: With the canvas in place, the next step is to create a T-Spline primitive form on
the proper plane.
Step 1 – Start the box primitive
1. Click the Create > Create Form icon to
enter the Sculpt workspace.
2. Click Create > Box.
3. Select the same side plane (YZ) as the
canvas to specify the plane that the Box is
placed on.
4. Click once at the origin to specify the Box’s
center point
5. Move the mouse and click again to draw
its 2D profile.
Step 2 – Specify the box primitive

Launch Video

1. Set the Box’s Length, Width, and Height
equal to 175, 35, and 25 mm, respectively.
2. Set the number of Length Face equal to 5,
and the width and height faces equal to 2.
Looking at the form of the utility knife, the
complexity is along the length of the knife, so we
set additional faces in that direction. We can
always add or remove these later on.
Step 3 – Add symmetry

Launch Video

1. In the dialog window, change the
Symmetry from None to Mirror.
2. Check the box for Height Symmetry.
3. A green line is displayed that indicates
where we have symmetry set up.
4. With no more symmetry to add to our
form, click OK.
Launch Video
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Edit the T-Spline Form: Our T-Spline primitive is now in place, but we need to edit its geometry to better
match our reference picture. In the following steps, we’ll edit our existing geometry to match the canvas
as best as we can. After that, we can add and subtract more edges to fine-tune our design.
Step 1 – Start the Edit Form command
1. Click Modify > Edit Form.
2. For simplicity, ensure you’re looking at the
form from the Right view. To set this, you
can click Right on the view cube.
Common to most workflows, we stick to modifying
our form from just one view, proceeding to 3D
manipulations as a final step.

Launch Video
Step 2 – Select a loop of faces
1. Select the middle loop of faces going down
the length of the utility knife with a
window selection (left-click and hold), as
shown in the picture.
2. Dragging left to right will select all the
geometry that is fully captured by the
window, while right to left will capture
everything that touches the window.
Launch Video
Step 3 – Start modifying the form
1. Using the Planar Translation manipulator,
move the selected faces to align the top of
the T-spline body with the top of the utility
knife.
2. To align the bottom in this section, select
the bottom face and use the planar
translation and rotate manipulators.
3. Repeat the previous 2 steps for the rest of
the T-spline form. It will also be helpful to
use the single-direction scale manipulator
in some cases.
4. For more controlled editing, try modifying
individual edges.
5. Don’t worry if the finer details of the
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contour are not matched, as we will
accomplish this in the next step by adding
and subtracting edges. Shoot for the image
on the right!

Launch Video

Add Additional Details – Insert Edge: Our T-Spline form is starting to resemble our reference image, but
there are without a doubt some details that we need to add! As the form is right now, there simply are
not enough edges available to capture all of the details that we would like. To combat this, you
implement the earlier-discussed method of inserting and deleting edges into a T-Spline form.
Step 1 – Insert additional edges
1. Hold Shift then select the edges shown.
2. Click Modify > Insert Edge.
3. Drag the direct manipulator to the right to
position the new edges at an Insert
Location around -0.5.
4. Click OK.
We’ll now repeat the previous steps to insert
another set of edges.
Step 2 – Insert more edges

Launch Video

1. Holding Shift then select the edges shown.
2. Click Modify > Insert Edge.
3. Drag the direct manipulator to the right to
position the new edges at an Insert
Location around -0.5.
4. Click OK.
The form will change due to the additional edges.
In the next step we will edit our form to our liking.
Step 3 – Edit Form

Launch Video

1. Use the Edit Form command to
manipulate the recently inserted edges to
achieve the result shown on the right.
2. The planar translation manipulator will be
extremely useful.
As you can see, the reference image will help us
roughly capture the correct form, but the fine
details are entirely up to us.

22

Launch Video

Autodesk Fusion 360: Sculpt

Add Additional Details – Insert Point: To insert the final two edges we need, we’ll actually learn a new
command, the Insert Point command. Slightly different from Insert Edge, the Insert Point command will
easily insert an edge by connecting two points together.
Step 1 – Start the Insert Point command
1. Click Modify > Insert Point.
2. Hover over the middle of the top edge
shown until a red circle appears – this
indicates the midpoint
3. Click and repeat for the edge directly
beneath, located along the line of
symmetry.
Launch Video
Step 2 – Insert Point details
1. Leave the Insert Mode set to Simple.
2. Click OK.
An Insert Mode of Simple will add the desired
edge, but the form will change slightly. An Insert
Mode of Exact will add the desired edge, as well as
additional edges to maintain the previous form. As
you can tell, this setting will be a trade-off
between maintaining form and reducing the
number of edges.
Step 3 – Repeat Insert Point
1. Click the Modify > Insert Point.
2. Construct an additional edge as shown to
the right.
3. Leave the Insert Mode set to Simple.
4. Click OK.

Launch Video
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Step 4 – Edit Form
1. Use the Edit Form command to
manipulate the recently inserted edges (as
well as the surrounding geometry) to
achieve the result shown on the right.
2. Click Finish Form.
Congratulations! You’ve completed your first
sculpting workflow in Fusion 360. Feel free to
sculpt the utility knife’s sides for even more detail.
With a more complex form, a similar workflow can
be utilized, but with multiple calibrated canvases.
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